虚拟主机常用组件版本及参数支持情况(不支持反解析)

 

虚拟主机常用组件版本支持情况

组件(扩展)

Linux

windows(2008、2012、2016、2019)

版本信息

说明

php memcache (memcached)支持支持服务端版本1.4.4
php sendmail 不支持不支持
可用PHPMailer模块替代
php openssl支持支持

fileinfo支持支持
有服务器可能未开启,如果不支持,提交工单开启
SourceGuardian(sg11)支持
不支持
linux主机点击参考教程
redis支持支持服务端版本3.2.100
除php5.2不支持,其他php版本均支持
php curl支持支持

gzip压缩支持支持
港台主机、存在CDN的主机检测不到,但实际是支持的
php zip支持支持1.8.11
php GD库支持支持2.0.34
php sockets支持支持

rewrite重写支持支持

php pdo_mysql支持支持5.0.51a
asp Jmail不支持支持4.3.0
asp FSO不支持支持

asp 动易组件不支持支持

php exif支持支持
若未安装,可更换到linux系统。
zend optimizer支持支持3.3.0仅php5.2版本
Zend Guard Loader支持支持3.3php5.3以后版本
asp 刘云峰上传组件不支持支持

ASPUpload上传组件不支持支持3.0.0.5
ASP.net Core不支持支持3.1
php iconv支持支持

php zend framework支持支持
推荐使用linux系统
php mbstring支持支持

ASPEncode
不支持支持
linux系统不支持asp
php fsockopen支持支持

php ioncube
支持支持
PHP加密
php ftp支持支持
windows系统支持。linux系统php5.2支持,其他版本未编译。
php intl支持支持

php iuc支持支持

magic_quotes_gpc支持支持
只有php5.3支持
short_open_tag支持支持

AspEmail.dll×支持

opcache支持支持
5.5以上版本开启

虚拟主机服务端版本支持情况

环境

linux系统

windows(2008、2012、2016、2019)

版本信息

说明

IIS不支持iis7/iis7.5/iis8/iis10

Apache2.4.33不支持

Mysql支持支持5.1/5.6/5.75.7少部分安装,不支持可提交工单更换
PHP5.2/5.3/5.4/5.5/5.6/7.0/7.1/7.2/7.35.2/5.3/5.4/5.5/5.6/7.0/7.1/7.2/7.3/7.4/8.0
主机控制面板php版本 可切换,linux切换后可进入others目录编辑php.ini
Javajava主机支持不支持
支持Servlet2.4,jsp2.0,Struts1,Struts2,Spring,Hibernate,proxool,javamail等
Tomcatjava主机支持不支持5.5.27/6.0.18/7.0/8.0/9.0若主机控制面板不能切换7.0,提交工单更换
JDKjava主机支持不支持JDK 1.6/1.7/1.8tomcat 5.5.27/6.0.18使用jdk1.6,tomcat7.0使用jdk1.7
MVC框架不支持支持
需要mvc4请选择windows2008系统,mvc5需要单独安装
ASP.NET不支持支持/2.0/3.5/4.0/4.7/4.82.0/3.5/4.0/4.7/4.8服务器会定期更新补丁,会支持微软最新版
Python不支持不支持
请购买云主机配置运行环境
Node.js不支持不支持
建议购买云主机自己部署环境
Sqlite已安装支持3.7.9linux已安装,windows支持php扩展
sqlserver不支持支持2000/2005/2008/2012/2014/20162000和2005少部分服务器

 

注: 如果还有其他不清楚的,请提交工单咨询。


打印 】